Friday, September 19, 2014

Multipoint Tunnels Dynamic

Automatic 6to4

#int loopback0 - es rom advertisement-debodes ar dagaviwydes
#ip address 1.1.1.1 255.255.255.255

#int tunnel0
#tunnel source loopback0
#ipv6 address 2002:101:101::/128
#tunnel mode ipv6ip 6to4

#ipv6 unicast-routing
#ipv6 route 2002::/16 tunnel0

#int f0/0
#ipv6 address 2002:AABB:CCDD:1::1/64
#ip address 170.187.204.221 255.255.255.0
#no shut :P



 #tunnel mode ipv6 isatap
# ipv6 address prefix/64 eui-64 (0000:5EFE as 5th and 6th quarters)


Point-to-Point Tunnels



#interface tunnel0
#ipv6 address 2001::1/64
#ipv6 eigrp 1
#tunnel source loopback 1
#tunnel destination 10.0.0.1
#tunnel mode ipv6

conf t
#ipv6 unicast-routing
#int f0/1
#ipv6 address 2002::1/64
#ipv6 eigrp 1

conf t
#ipv6 router eigrp 1
#router-id 1.1.1.1
#no shut

#show int tunnel0
#show ipv6 int (brief)
#traceroute ipv6 2111::1

FF02::1:FF0:0/104

 http://en.wikipedia.org/wiki/Solicited-node_multicast_address

A Solicited-Node multicast address is an IPv6 multicast address valid within the local-link (e.g. an Ethernet segment or a Frame Relay cloud). Every IPv6 host will have at least one such address per interface. Solicited-Node multicast addresses are used in Neighbor Discovery Protocol for obtaining the layer 2 link-layer addresses of other nodes.[1]

A Solicited-Node multicast address is created by taking the last 24 bits of a unicast or anycast address and appending them to the prefix ff02::1:ff00:0/104.[2] It is important to realize that we have taken 104 bits from the address, so that the last byte of the penultimate field 00 is not used in the prefix.

 ff00:0000   6x4=24 


A host is required to join a Solicited-Node multicast group for each of its configured unicast or anycast addresses.
Example: If we have an interface with the IP address fe80::2aa:ff:fe28:9c5a the associated Solicited-Node multicast address is ff02::1:ff28:9c5a. So we must join to the multicast group represented by this address.

Working Example

Assume a host needs to make a local delivery to another host on the local network, and the target host has an IPv6 address of fe80::2aa:ff:fe28:9c5a (as in Example 2 above). In order to make a Layer-2 (e.g. Ethernet) delivery, it needs to know the target host's hardware address (e.g. "Ethernet MAC address"). But in order to do this, it must first determine which hardware address to send it to. To do this, an IPv6 host will construct the Solicited-node Multicast Address related to the target address.


FE80

 ყოველთვის იწყება fe80::/64 ანუ პირველი 64 ბიტი არის FE80+ ნოლები. განსხვავება არის როგორ აყალიბებს დანარჩენ 64 ბიტს.

როცა ეხება ლან ინტერფეისს:
იღებს ამ ინტერფეისის 48 ბიტიან მაკს, მეშვიდე ბიტს ატრიალებს, და შუაში (6 ჰექსის მერე) ჩასვავს FFFE

როცა ეხება სერიალ ინტერფეისს + GRE tunnel :
აიღებს პირველი ლანის მაკ მისამართს და ჩასვავს იგივე ფორმულით. – დატესტე გნსში გაუწერე აიპის რო უწერ ბოლოშუ ეუი 64 და რას მიცემს

როცა ეხება ტუნელს (manual configured; 6to4):
აიღებს ამ ტუნელის source მისამართის 32 ბიტ აიპი მეოთხე ვერსიის მისამართს, გადაიყვანს ჰექსში და ჩასვავს ბოლოში. წინ შეავსებს ნოლებით.

 ასევე აიპი მეექვსე ვერსიას როცა აძლევ ინტერფეისს:
შეგიძლია გაუწერო მარტო პრეფიქსი, პრეფიქსის სიგრძე და მერე eui-64 და მაკით მისცემს უნიკალურ აიპის.

ასევე როცა autoconfig–ია, აგზავნის NDP პროტოკოლით მულტიკასტს და გვერდითა როუტერი ეტყვის რა პრეფიქსია და მერე ეს თავისი მაკის მიხედვით დაიდებს აიპის.

Thursday, September 18, 2014

IPv6 Commands

#int s0/1
#ipv6 address....
#ipv6 address autoconfig

#show ipv6 neighbors = show arp
#clear ipv6 neighbors
#show ipv6 router - აქ ნახავ თუა autoconfig

Link-local manual config:
#int f0/0
#ipv6 address FE80::1:2:3 link-local

#conf t
#ipv6 unicast-routing - ამის გარეშე არ დააფორვარდებს IPv6 პაკეტებს :О





 

RIPv2 vs RIPng + EIGRP for IPV6 + OSPF v3 + Redistribution

ipv6 unicast routing
ipv6 router rip NAME

int f0/0:
ipv6 enable
ipv6 rip NAME enable

#show ipv6 rip (=show ip prot for ipv4)
#show ipv6 router rip
#show ipv6 protocols
#show ipv6 rip next-hop 
-----------------------------------------------------------------------------------------------------

EIGRP:

#conf t
#ipv6 unicast-routing
#ipv6 router eigrp ASN
#int f0/0
#ipv6 address 2005::1/64 /ipv6 enable
#ipv6 eigrp 1
#router ipv6 eigrp 1
#no shutdown
#eigrp router-id 1.1.1.1 (თუ ვერ აიღო იმიტორო არაა ipv4 დაკონფიგებული არცერთ ინტერფეისზე)

------------------------------------------------------------------------------

OSPF:

#conf t
#ipv6 unicast-routing
#ipv6 router ospf 1
#int f0/0
#ipv6 address 2006::1/64
#ipv6 address enable
#ipv6 ospf 1 area 0

#ipv6 router ospf 1
#router-id 1.1.1.1 


-------------------------------- ----------------------------------------------------
#ipv6 router rip NAME
#redistribute ospf 1 include-connected

#ipv6 router ospf 1
#router-id 1.1.1.1
#redistribute rip NAME route-map WORD include-connected metric 3

#ipv6 route 2000::/64 f0/0 FE80::213:19FF:FE78:5005

#show ipv6 route 2000::/64 - დეტალებისთვის




Sunday, September 14, 2014

BGP Commands

Implementation:

#router bgp 6500
#neighbor 10.45.1.1 remote-as 5500
#neighbor 10.45.1.1 password (encryption 0-7) WORD 
#neighbor 2.2.2.2(იმის Loopback) update-source loopback0 (საკუთარი loopback)
#neighbor 2.2.2.2 ebgp-multihop <1-255>  (default 1)
#neighbor 1.1.1.1 shutdown
#neighbor 1.1.1.1 distribute-list <ACL N> in/out
#neighbor 1.1.1.1 prefix-list NAME in/out
#neighbor 1.1.1.1 filter-list <ACL N> or <ip as-path N> in/out
#neighbor 1.1.1.1 route-map WORD in/out
#neighbor 1.1.1.1 soft-reconfiguration inbound
#neighbor 1.1.1.1 weight <0-65535>  (higher better)
#bgp router-id 1.1.1.1
#network 4.4.4.0 (mask 255.255.255.0)
#auto-summary
#aggregate-address 128.127.0.0 255.255.240.0 (summary-only)
#synchronization
#bgp default local preference 700 (default 100, higher better)
#default metric (default 0)
#maximum-paths <1-16> 



#set as-path prepend 3 3



#show ip bgp summary
#show ip bgp neighbors (A.B.C.D)
#show tcp brief
#debug ip bgp
#show ip bgp = lists BGP table
#show ip bgp nei 1.1.1.1 advertised-routes
#clear ip bgp  1.1.1.1 
#clear ip bgp *
#clear ip bgp 1.1.1. out
#clear ip bgp 1.1.1. soft out
#clear ip bgp 1.1.1.1 in
#clear ip bgp 1.1.1.1 soft in
#clear ip bgp * soft
#show ip bgp neighbor 1.1.1.1 advertised-routes
#show ip bgp neighbor 1.1.1.1 received-routes
#show ip bgp neighbor 1.1.1.1 routes
#show ip bgp rib-failures  (Routing Information Base= routing table)

Thursday, September 11, 2014

BGP loop

E1 E2 არის "შეთანხმებული" პროვაიდერთან რომ 192,135,250,0/28–მდე მივა I1-2–ს გავლით. Core1 არაა BGPში ჩართული და არ იცის ამის შესახებ, ამიტომ ხდება ლუპი


Wednesday, September 10, 2014

BGP AS_Path


reserverd and private


IP SLA (Service Level Agreement) Commands

The IOS IP Service-Level Agreement (IP SLA) feature measures the ongoing behavior of
the network. The measurement can be as simple as using the equivalent of a ping to determine if an IP address responds, or as sophisticated as measuring the jitter (delay variation)
of VoIP packets that flow over a particular path. To use IP SLA, an engineer configures IP
SLA operations on various routers, and the routers will then send packets, receive responses, and gather data about whether a response was received, and the specific characteristics of the results, such as delay and jitter measurements.

#conf t
#ip lsa 11
#icmp-echo 10.1.3.99 (destination) source-ip 10.1.1.9
#frequency 60
#ip sla schedule 11 start-time now life forever
#no ip sla 11

PBRს რომ მიაბა რომ კონკრეტული გზით იაროს ვთქვათ:
#access-list 101 permit ip host 10.1.1.9 host  10.1.3.99
#ip local policy NAME
#route-map NAME permit
#match ip address 101
#set ip next-hop 10.1.2.3

Tracking:
#track 2 ip sla 11 state/reachability
#delay up 90 down 90 - optional
#ip route  10.0.0.0 255.255.255.0 s0/0 track 2

#ip next-hop verify-availability 10.0.0.1 25 track 2

#show track

#show ip sla configuration
Entry number = operation number (11)

#show ip sla statistics 11
Latest operation return code: OK/ No connection
Number of successes: 22

Tuesday, September 9, 2014

Policy Based Routing Commands

#int s0/0
#ip policy route-map NAME - enables Policy Based Routing

#route-map NAME permit
#match ip address 100
#set ip next-hop 10.1.14.4 (neighbor)

#access-list 100 permit ip host 10.1.1.2 10.1.3.0 0.0.0.255 

set commands:
#set ip next-hop (ჯერ PRB)
#set ip default next-hop (ჯერ ჩვეულებრივად, ოღონდ default route დააიგნორე და მერე PBR)
#set ip interface
#set default interface ("-------")

QoS (for VoIP):
#set ip precedence <0-7>
#set ip tos  (<value>, min-delay .....)

global config:
#ip local policy route-map NAME  - იმავე როუტერის მიერ როუტერის მიერ შექმნილი პაკეტებისთვის. 


#debug ip policy

example


R1#route-map TAG1
R1#set metric 1000 33 255 1 1500
    R1# set tag 1
 router eigrp 1
redistribute ospf 1 route-map TAG1
    

Redistribution Commands

 OSPF into EIGRP:

#router eigrp 1
#redistribute ospf 1 -მარტო ამას თუ გაუწერ არ იმუშავებს, უნდა მეტრიკები. By default infinite metric აქვს ყველაფერს თუ მარტო სხვა EIGRP პროცესიდან არ აკეთებ რედისტრიბუციას. <match Internal External Nssa-external> <metric> <route-map>

არსებობს 3 გზა რომ გაუწერო მეტრიკა:
1. #router eigrp 1
    #default metric 1000 33 255 1 1500 (bw delay rel load mtu)
ამ ბრძანების შემდეგ ყველა რედისტრიბუცია განხორციელდება ამ მეტრიკით.

2. #router eigrp 1
    #redistribute ospf 1 metric 1000 33 255 1 1500

3. #route-map OSPF-To-EIGRP
    #set metric 1000 33 255 1 1500
    #router eigrp 1
    #redistribute ospf 1 route-map OSPF-To-EIGRP
    - ეს გზა overrideს პირველ ორ გზას.


AD რომ შევცვალოთ:
#router eigrp 1
#distance  eigrp 90 (internal) 105 (external)
#distance  180 A.B.C.D (neighbor router's IP, who advertises the route) 0.0.0.0 (wildcard) 1 (access-list N)



--------------------------------------------------------------------------------------------------------------
EIGRP into OSPF 

#router ospf 1
#redistribute eigrp 1 subnets (თუ არ გაუწერ "subnets", მაშინ მარტო classful network-ების რედისტრიბუციას გააკეთებს) <metric> <metric-type> <route-map> <tag>

E2 კარგია როცა არის 2 ASBR და გინდა 1დან იარონ. მაგ ASBRზე დაუწევ მეტრიკას:
#redistribute eigrp 1 metric 10


E1 კარგია როცა გინდა closest ASBR აირჩიოს თითოეულმა როუტერმა.

თუ E1ც გაქვს დაკონფიგებული და Е2ც, OSPF აირჩევს E1s

AD რომ შევცვალოთ:
#router ospf 1
#distance ospf (external, inter-area, intra-area)
#distance 171 1.1.1.1 (router ID of the LSA Type 5 creator router) 0.0.0.0 (wildcard mask) 1 (access-list N)
#ip access-list standard 1 permit host 172.20.0.0

#router rip
#distance <1-255>



Route Maps
#route-map REDISTRIBUTION
#match interface
#match ip address 1 (ACL number/name)
#match ip address prefix-list NAME
#match ip address next-hop 1 (ACL number/name)
#match ip route-source 1 (ACL number/name)
#match metric 100 +- 10
#match route type (internal,external (type1, type2), nssa-external, level 1, level 2)
#match tag 30

#set metric 10 (თუ OSPFსთვის)
#set metric <bw delay reliability loading mtu> (თუ ЕiGRPსთვის)
#set metric-type type-1/type-2 (OSPF)
#set tag 40



Verification Commands:
#show route-map
#show ip prefix-list
# show ip route 10.4.0.0 (to see the tag, router ID, protocol redistributed from, etc.-ეს OSPF)
#show ip eigrp topology - ჩანს Redistributed, tag
#show ip eigrp topology 172.16.48.0/25 - გვაჩვენებს რომელი პროტოკოლიდან მოდის, რა მეტრიკით, რომელმა როუტერმა გააკეთა რედისტრიბუცია"this system" ანუ ამ როუტერმა.
#show ip ospf database asbr-summary
#show ip ospf border-routers -გაჩვენებს როგორც ABRებს, ისე ASBRებს რომლებთანაც გაქვს კავშირი ABRების გავლით. ასევე გაჩვენებს რომელ არეებში არიან ABRები და ASBRები და რომელ ABR არის გამოყნებეული რომ მიაღწიოს АSBRს. ასევე cost. 
 #show ip ospf database | begin ASB
"Summary ASB Link States" = Type 4 LSA
LinkID = ASBR, ADV Router = ABR
"Type 5 AS External Link State"
LinkID = external routes, ვთქვათ EIGRPს საბნეტები, ADV Router = ASBR რომელთანაც პირდეპირი კავშირი არც გვაქვს, მაგრამ Type 4 LSAში ჩანს რომელი ABR-ების გავლით ხვდება მაგ ASBRთან.
#show ip prefix-list detail NAME ( hit count: 1)
#show access-list (1 match)
#show ip protocols | section ospf - ვნახავთ default distance თუ აქვს რამე Gatewayს შეცვლილი. 


Thursday, September 4, 2014

FRAME_RELAY



Point-to-Point

R1#int s0/0/0
encapsulation frame-relay
ip address 10.0.0.1 255.255.255.248

R2#int s0/0/0
encapsulation frame-relay
ip address 10.0.0.2 255.255.255.248

R3#int s0/0/0
encapsulation frame-relay
ip address 10.0.0.3 255.255.255.248

R4#int s0/0/0
encapsulation frame-relay
ip address 10.0.0.4 255.255.255.248

IOS enables Frame Relay InARP by default, so all four routers learn other routers IP address/DLCI mappings dynamically. 
After creating this configuration, the four routers can ping each other if the PVC link exists between them. For example, in Partial-Mesh design, R2 and R3 can't ping each other.
--------------------------------------------------------------------------------------------------------------------


Multipoint 

When using subinterfaces, IOS needs a command under Frame Relay subinterface that associates each PVC with that subinterface:
frame-relay interface-dlci <number> - just associates DLCI with subinterface, relying on Frame Relay Inverse Arp to discover mappings.
frame-relay map  - statically configures mapping, while also associating DLCI with subint.


R1#int s0/0/0
 no ip-address
encapsulation frame-relay
int s0/0/0.1
ip address 10.0.0.1 255.255.255.248
frame-relay interface-dlci 102
frame-relay interface-dlci 103
frame-relay interface-dlci 104

დანარჩენ 3 როუტერზეც ანალოგიური კონფიგურაცია, და ვიღებთ იგივე შედეგს რაც პირველ ვარიანტში: ერთმანეთთან ვისაც აქვს PVC დაპინგავენ ერთმანეთს, ვისაც არ აქვს – ვერა.
 

Monday, September 1, 2014

OSPF COMMANDS

Implementation Commands:

#router ospf <process ID>

# network 10.0.0.0 0.0.0.3 area 0
# area 0 authentication
# area 0 authentication message-digest
# passive-interface s0/0
# defaul-information originate
# network 0.0.0.0 255.255.255.255 area 2 - "go find any active interfaces and place it into area 2"
# max-lsa 1000 <ignore-count, ignore-time, reset-time, warning-only>
# maximum-paths <1-16>
# auto-cost reference-bandwidth
#area 1 default-cost 10 
#area 1 stub <no-summary>
#redistribute eigrp ASN subnets
#no area 1 stub
#area 1 nssa <no-summary>
#area 2 virtual-link 2.2.2.2 <authentication> <hello-interval>

#int f0/0
#ip ospf authentication null
#ip  ospf authentication
#ip ospf authentication-key <0-7> LINE
#ip ospf authentication message-digest
#ip ospf message-digest-key <1-255> md5 <0-7> LINE 
#ip ospf network <broadcast> <non-broadcast> <point-to-point> <point-to-multipoint>
#ip ospf dead-interval 40
#ip ospf hello-interval 10 
#ip ospf cost 10
#ip ospf 3 area 0
#ip ospf dead-interval minimal hello-multiplier 4
#ip ospf priority 255


Verification Commands:

#debug ip ospf adj
#show ip ospf 
#show ip ospf database
#show ip ospf int f0/0
#show ip ospf neighbor
#show ip int s0/0 (for MTU)
#show ip ospf database router A.B.C.D
#show ip ospf database network A.B.C.D
#show ip ospf database summary A.B.C.D
#show ip ospf database database-summary 
#show ip ospf virtual-link 

Friday, August 29, 2014

CCNP EIGRP COMMANDS




Implementation Commands:
# router eigrp ASN


# no auto-summary
# network 192.168.0.0 0.0.0.3
# network 0.0.0.0
# passive-interface f0/0
# passive-interface default
# no passive-interface f0/0
# neighbor 10.0.0.3 s0/0
# maximum-paths <1-16>
# variance <1-128>
# metric maximum hops  <1-255>
# metric weights 0 <1-255> <1-255> <1-255> <1-255> <1-255>
# redistribute <static> <connected> etc. 
# eigrp router-id A.B.C.D (show ip eigrp topologyში ჩანს)
# eigrp stub <'connected' and 'summary' by default>
# offset-list <acces-list number> in/out <offset number> <interface number>
# timers active-time <in minutes>/<disabled>  (disabled defaultad anu tu <cr>)
# distribute-list  2 (access-list number) in/out
# distribute-list prefix WORD in/out/gateway (?)



# int s0/0


# no ip split-horizon eigrp ASN
# ip summary-address eigrp ASN 10.0.0.0 255.255.252.0 5
# ip bandwidth-percent eigrp ASN 80 <number of percent>
# ip authentication mode eigrp ASN md5
# ip authentication key-chain eigrp ASN WORD
# ip hello-interval eigrp ASN <seconds>
# ip hold-time eigrp ASN <seconds> 

 # conf t


# key chain WORD
# key 1 (must match)
# key-string cisco1 (must match)
# accept-lifetime 00:00:00 1 Jan 2014 00:00:00 31 Jan 2014 (ან duration <seconds>; infinite)
# send-lifetime "--------------------------------"
# ip prefix-list WORD seq <number> deny/permit 10.0.0.0/8 ge 24 le 24
# ip default-network 192.168.0.0
# ip route 192.168.0.0 255.255.255.0 Null0


Verification Commands:
# show ip route  10.0.0.0 255.255.248.0 longer-prefixes
# show ip protocols
# show key chain
# show ip eigrp interfaces
# show ip eigrp interfaces detail - hello interval chans
# show ip eigrp neighbors
# show ip eigrp neighbor detail - ჩანს სტატიკური neighborები
# show ip eigrp topology
# show ip eigrp topology all-links – ჩანს არა FS routeბიც.
# show ip prefix-list 

#clear ip eigrp neighbors